Need to add /index.html to access index page

My website URL is:
If I just type I get a message “This page isn’t working.” If I add “/index.html” I get to my index page. How can I set it up so visitors don’t have to add the suffix?

The site was constructed using SoftPress-Freeway Express

Your main index file the server loads (without index.html) returns a 500 Internal Server Error:

The reason your website only works with /index.html added to the URL, is because of the files you have in your htdocs folder, and the way the server uses them.

Our servers look for the main file of your directory by checking index.php, index.html and index.htm. The first file they find (looking in that order) is loaded as the main page of the folder (and, since this is the main folder of your site, your home page).

In your account, I see you have an index.php, index.html and index.htm file. Since the server looks for an index.php file and found it, it loads the index.php page. And the code of this page crashes.

To fix this issue, the best way to do it is to simply remove the files from your account which do not belong to your website. So if you want index.html to be used as the main page, you should remove the index.php and index.html files. But you can also change which file is loaded as the main page by setting a .htaccess rule for DirectoryIndex.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.