MYSQL/PHPmyadmin issues

I’m not a newb, but having issues with MySQL.

  1. PHPMyadmin does not show my databases after the initial view. When I click on the database tab, it asks me to create a database (with the name of the database already there). Then when I click on it, It says database already created. I can’t see my tables unless I log in to PMA again.

noticed this error: Your PHP MySQL library version 5.1.73 differs from your MySQL server version 5.6.35. This may cause unpredictable behavior.

  1. I am having trouble getting into mysql with pdo. I checked the cpanel on the parameters to use, but keep getting this error:

PDOException Object ( [message:protected] => SQLSTATE[HY000] [1045] Access denied for user ‘epiz_XXXX’@‘192.168.0.37’ (using password: YES) [string:Exception:private] => [code:protected] => 1045 [file:protected] => /home/vol1_8/epizy.com/epiz_XXXX/htdocs/upcapi.php [line:protected] => 5 [trace:Exception:private] => Array ( [0] => Array ( [file] => /home/vol1_8/epizy.com/epiz_XXXX/htdocs/upcapi.php [line] => 5 [function] => __construct [class] => PDO [type] => → [args] => Array ( [0] => mysql:host=sql104.epizy.com;dbname=epiz_XXXX_upcdata;charset=utf8mb4 [1] => epiz_XXXX [2] => YYYYYY ) ) ) [previous:Exception:private] => [errorInfo] => )

Note, password was copied from the password popup and the same as I use for ftp, triple check.

Thanks!

I just tried to access the database stuff on your account and everything worked. Both phpMyAdmin and your script seem to be working fine. There might have been a hiccup when you first created your database, but it seems to have been resolved now.

Thank, you
ok I’ll try again…
Have to update the scripts

Ok, tried again, and another free host too, which had similar issues.
I seemed to have populated the database.

However, PMA does not work.
Got this:

The 185.27.134.10 page isn’t working

185.27.134.10 didn’t send any data.
ERR_EMPTY_RESPONSE

I believe my php query is correct and does not work either.

Maybe populating all that data and dumping status isn’t ok for free hosting? Did I exceed anything? I can suppress printing.

Thanks

Again, phpMyAdmin works fine for me. Can you please try to clear your cookies for the control panel and 185.27.134.10?

Your script also doesn’t seem to produce any errors for me.