MYSQL doesn't work

My website URL is: www.letradourada.epizy.com

**What I’m seeing is: Nothing appears in my MYSQL tables url:

**

**I’m using this software: **

**Additional information: Apparently everything is fine with the MSQL’s connection but the content doesn’t appear. **

Can you share your code that you are using to access the table content??

For me it now works; for you it’s just a caching issue, so try to refresh with Ctrl and F5.

1 Like

Thanks a lot for your answer. I tried your suggestion but, unfortunately, in my case, the problems persists.

Then you need to configure 1.1.1.1 on your device.

What do you mean with code?

Did you check the database in phpMyAdmin to check whether the data is there?

Yeah. I checked that and the error persists: Failed to load resource: the server responded with a status of 500 (Internal Server Error). It’s a message in my browser.

What a hell is that?

Uncaught TypeError: a is not a function
at bootstrap.min.js:7
at bootstrap.min.js:7

This is a server error. See this article for more info.

This is a client (i.e. browser code) error. This is a completely different issue.

1 Like

Okay. I understand that but how is it happens from one day to another? It is so strange because the php page was working fine and suddenly crashed. Do you have any suggestion to solve this?

Please enable “Display Errors” from “Alter PHP Config” on the Control Panel so that I can help you to solve the errors on your code.

1 Like

Deprecated : mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/vol1_2/epizy.com/epiz_23436757/htdocs/ultimahora/database/mysql.php on line 45

Fatal error : Uncaught Error: operator not supported for strings in /home/vol1_2/epizy.com/epiz_23436757/htdocs/ultimahora/database/mysql.php:100 Stack trace: #0 /home/vol1_2/epizy.com/epiz_23436757/htdocs/ultimahora/database/mysql.php(78): mysql->fetchAll() #1 /home/vol1_2/epizy.com/epiz_23436757/htdocs/ultimahora/noticias.php(19): mysql->query(‘select * from …’) #2 {main} thrown in /home/vol1_2/epizy.com/epiz_23436757/htdocs/ultimahora/database/mysql.php on line 100

On line 45, replace mysql_connect with mysqli_connect to remove the “Deprecated” message, then use on all the code the mysqli extension.

We upgraded our PHP version from PHP 7.0 to PHP 7.3 a few weeks ago. So that might have broken your website code.

The mysql_XXX functions were removed with PHP 7.0 and only worked on our hosting because of a backward compatibility hack. You can “fix” this by changing your account’s PHP version to 5.6, or actually fix it by removing all mysql_XXX functions and use mysqli or PDO instead.

1 Like

Solved. Thank you so much for your help! :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.