My site went down after i put cloudflare on it

https://eshhub.cf

Error 525

(when i try to access my site it gives error 525 SSL handshake failed i dont know whats wrong i am using freenom and infinity free when i put the cloudflare nameservers on my freenom nameserver management it works but i get the error how do i fix this??)

2 Likes

Use the cloudflare Flexible SSL. Yours might be on Full or Full Strict

5 Likes

yes it is on full

change it to flexible

1 Like

we dont support Full mode

i changed it but it still is not loading

Not likely, if you want Full encryption, you must install SSL certificate first, then add CloudFlare

4 Likes

clear your browser cache ctrl+f5

thanks

1 Like

np

Setting Cloudflare SSL Full Mode requires a Valid SSL Certificate on your domain. You can get free SSL Certs for your domain using the SSL Tool.

If you don’t want the fuss of that, then set Cloudflare to Flexible which means you don’t need an SSL Cert on your domain.

2 Likes

my site wont work with https now eshhub.cf sent an invalid response. i think it may be something with my nameservers now as when i was first setting up cloudflare it told me to remove epizy but i never did

but im not sure ebcause it was fine a minute ago

use epizy nameservers and add cloudflare from VPanel

i would but if i do that i cannot config my cloudflare through cloudflare.com

Nameservers take 5 minutes to 72 hours to propagate

2 Likes

i want to be able to change my cloudflare settings with cloudflare.com

if you want to use Cloudflares nameservers, you have to do it via an addon domain. If you change main domain’s nameservers, it will stop functioning

That doesn’t work

Alternative method:
Install a free SSL from GoGetSSL or Lets Encrypt, and activate both SSL from cloudflare and IF
that might work

1 Like

don’t combine 2 nameservers.

3 Likes