My site is not loading in https even when I changed htaccess

Username (e.g. epiz_XXX) or Website URL

epiz_27087595

(please specify the website or account you are asking about)

Error Message

My site was not loading https so I tried to change htaccess to add the rewrite rule but I got this message "Error During Ftp upload, permission denied at “/.htaccess” ", then I saw a post here that I should change the htaccess at the htdocs folder and that’s what I did, I added the rewrite rule at htdocs/htaccess but still my website is not loading in https.

Other Information

provide your website url so that I can chck.

www.camzbabes.com

If you have ssl (which you can get free from control panel) i’d recommend waiting for at least 10-12 hours before you’re https works :slight_smile:

Yea but it’s been more than 24 hours

as far as i can see your https works and your site have an let’s encrypt x3 ssl certificate :slight_smile:

1 Like

Really? is not working for me, when I try with https:// yea but when I try with only domain name like www it’s not

i dont think you need to use www as everyone (on my opinion) uses https :slight_smile:

but there are gonna be people who write camzbabes.com and in this case they’re gonna go to http version, that’s what I want to fix.

i’m not sure about that as you can see i’m still a newbie :slight_smile:, as far as i know, cloudflare does the http to https redirecting thing on its own . check sincity.cf (my site) for an example .

1 Like

That’s exactly what I wanna do,well if there is no way to do it without cloudflare then I have to consider using cloudflare.

1 Like

if it helps make sure to press the green button to mark the topic as solved so the forum stays clean :slight_smile:

It also says so in all caps at the top of the file you were editing. Maybe that’s not clear enough, you’re not the first to completely overlook it. But I’m at a loss how to make it more clear given how it’s not possible to have flashing lights and alarm sounds in a text file.

The file needs to be called .htaccess. The dot at the start is important. .htaccess works, htaccess doesn’t.

4 Likes

It’s working now, I forgot to add the . at the start of file, thank you very much.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.