Jquery Issues - Site Not Working Properly

Hi, I am trying to mimic this simple example: JS Bin - Collaborative JavaScript Debugging where it uses a static HTML for the code, CSS and javascript. When I do on an internal web server it works. When I do the same here I do not see the pull down menus or search box. Does anyone know why? I tried using the files locally instead of pointing to the nightly builds but can’t get it to work.


Welcome! Can you share your website URL?


Thanks! Here it is: https://thrive.epizy.com/myhometract/test.html

Ok, I managed to get the entire thing in one screenshot.

This is what I see:

If that is not correct, can you share the code you are using (Like in a Codepen / JSFiddle). And a screenshot of what it is supposed to look like.


The URL I put above is a “test” code similar to the same. If you look at the Output page, it shows how it should show with the page selection on the footer and header has the pull down menus as well as the search box.

If I mimic exactly how it shows on this URL: JS Bin - Collaborative JavaScript Debugging (I put on another webserver, internally) it works.

I’m going to guess that the code is not uploaded correctly. Can you open the file manager and verify it? Unfortunately, I’m on a mobile device at the moment and can’t check it for you.

Yeah. As far as I can tell, all is the same. Copy and Paste. Only after it was not working, I edited to “try” loading the file locally (CSS/JS) instead of the provided URL. Still same result.
A new pair of eyes might be able to identify it. Right now I am baffled.

No worries. When you are in front of a computer, maybe you could check.


When I open the page and check the Console tab in my browsers developer tools, I first see an error that the jQuery cannot be downloaded because it uses a http:// URL, whereas your site uses https://, and after that an error saying jQuery is missing.

So please update your code to make sure all URLs use HTTPS, because modern browsers will often refuse to load content over HTTP if the page is using HTTPS.


Amazing! That was it! New pair of eyes, quickly catches the silly mistake! Thanks a lot! :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.