Is FTP server down?

I have just created my account and I’m trying to connect to FTP using FileZilla. I think the problem isn’t username or password, but I got a time out server response. Look:

Error: Could not connect to server
Status: Waiting to retry…
Status: Resolving address of ftp.rf.gd
Status: Connecting to 185.27.134.11:21…
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

Would it be a server crash and I an unlucky guy to get it in my first try?
I can connect to other FTP server without problem, so my firewall is ok.

Thanks!

Well, the FTP server definitely isn’t down, because you seem to be the only one with this issue right now. Do you still experience this problem? If so, can you try to reset your account password and try again?

I can’t connect yet.
I think the problem isn’t the username/password, because the connection is not established.
I’ve tried connect in Command Prompt, typing:

ftp ftp.rf.gd
But the it doesn’t require my username and password, just can’t establish connection to server.
I also tried:
ftp 185.27.134.11
The same happens.

Is there a test login I could test?
Other FTPs servers I tried, I could connect quickly.

I tried restating my account and my ftp password. Same.
I also tried:

ping 185.27.134.11
No response.
Is there any type of restrictions to Brazilian IPs?

Sorry for multiple messages.

An interesting fact: I have tried connect to ftp using 2 different online tools:

Any idea what could be the problem? Thanks

We don’t block any IP addresses on our FTP servers.

Do you experience this problem on other devices and other networks as well?

I tried in an iPad, and the same occours.

I have made a test and changed my ISP routing my 4G internet. Yes, the FTP has worked (PC and iPad), but sometimes connect, sometimes not properly. Most important, the server answerd my ping command.
So, the problem probably is my ISP. I contacted them, but they didnt give me good answers.

I tried another FTP service, with free account (profreehost.com), and I noticed the FTP IP server is the same yours (185.27.134.11), although with different hostnames. And both have the same problem to connect - with one ISP, nothing works, including ping. Another, sometimes connects well, with ping ok. Other two servers I tried, no problem. Maybe my ISP blocks your IP (they say dont).

I will keep finding something with my ISP, if I have news I tell you.