Install Certificate Clouldflare

How to install cloudflare certificate using freenon domain?

@Bruno-Braga said:
How to install cloudflare certificate using freenon domain?

There are two methods:

  1. vPanel integration.
    First, go to vPanel → Software Section → Cloudflare – Press Enable for your domain – Wait for DNS to fully propagate → Done.

  2. Direct Cloudflare.
    First go to Cloudflare → Register an Account → Add your domain → Change your domain nameservers (once Cloudflare tell you to change your ns) → Wait for DNS to fully propagate → Done!

For the vPanel Integration gives this error:

CLOUDFLARE ERROR : Sorry there was a problem activating cloudflare for this domain or the email address [email protected], this is normally caused by the email address or domain name already existing on the cloudflare system.

@Bruno-Braga said:
For the vPanel Integration gives this error:

CLOUDFLARE ERROR : Sorry there was a problem activating cloudflare for this domain or the email address [email protected], this is normally caused by the email address or domain name already existing on the cloudflare system.

Maybe you have already registered to Cloudflare?

Try using method 2, it should work.

I used method two. Asked to add the InfinityFree name servers on Freenom. But in the cloudflare also asks and I do not know how to do.

Cloudflare Nameservers
To use Cloudflare, you need to change your domain’s authoritative DNS servers, which are also referred to as the nameservers. For your reference, here are the Cloudflare nameservers you’ve been assigned.

@Bruno-Braga said:
I used method two. Asked to add the InfinityFree name servers on Freenom. But in the cloudflare also asks and I do not know how to do.

Cloudflare Nameservers
To use Cloudflare, you need to change your domain’s authoritative DNS servers, which are also referred to as the nameservers. For your reference, here are the Cloudflare nameservers you’ve been assigned.

You will need to use InfinityFree’s name servers so you can add your domain here, and once you added your domain successfully here, you can change your name servers to Cloudflare so it can query all your existing DNS records.

I put the InfinityFree name servers on my domain website and then I come back with the name severs from my domain site to InfinityFree? And where do I put the name serves in InfinityFree?

@Bruno-Braga said:
I put the InfinityFree name servers on my domain website and then I come back with the name severs from my domain site to InfinityFree? And where do I put the name serves in InfinityFree?

Hi,
For better understanding, you can read this article:
https://techub.tk/free-ssl-free-hosting-ifreenet/

This article is made by a member here on IF.

@UnknownLolz said:

@Bruno-Braga said:
I put the InfinityFree name servers on my domain website and then I come back with the name severs from my domain site to InfinityFree? And where do I put the name serves in InfinityFree?

Hi,
For better understanding, you can read this article:
https://techub.tk/free-ssl-free-hosting-ifreenet/

This article is made by a member here on IF.

Two members, actually :lol:

Good Morning

I found it somewhat confusing besides that InfinityFree does not support the format “tk” e nor the site “SSLForFree”.

I have now made it through the Cloudflare of cpanel and have sent an email to create a password and already in Cloudflare website I am waiting for the certificate to propagate but then I do not know if I choose Full or Flexible and also how to configure the nameservers.

@Bruno-Braga if you’ve enabled cloudflare via cPanel → you don’t have to do anything with nameservers/dns cause it’s still being managed by InfinityFree.

I recommend to choose Full, InfinityFree is ssl-enabled by default and no problems with that mode should be occured.

.tk domain is not supported due to a lot of complaints about abuse.

I have been expecting dns to propagate in cloudflare yesterday and it has not spread yet. Now I’ve activated the cloudflare in the cpanel and gave this other error and I’m not even using Byethost.

“CLOUDFLARE ERROR : Your brunobragatutoriais.ml’s DNS is hosted by CloudFlare. If you’d like to switch to Byethost, you must first deactivate and then delete “brunobragatutoriais.ml” ;. These options are available in the Settings menu.”

@Bruno-Braga said:
I have been expecting dns to propagate in cloudflare yesterday and it has not spread yet. Now I’ve activated the cloudflare in the cpanel and gave this other error and I’m not even using Byethost.

“CLOUDFLARE ERROR : Your brunobragatutoriais.ml’s DNS is hosted by CloudFlare. If you’d like to switch to Byethost, you must first deactivate and then delete “brunobragatutoriais.ml” ;. These options are available in the Settings menu.”

This means that your Domain has successfully added to Cloudflare and if you want to deactivate Cloudflare for your domain then press the deactivate button.

Also you can’t edit your DNS because you have only added your domain through the integration, if you want full DNS management, then you will need to use method 2.

I got the Cloudflare site but in cpanel it still continues with the error above!

@Bruno-Braga said:
I got the Cloudflare site but in cpanel it still continues with the error above!

Can you please explain why and how did that error occur? What were you doing there?

I created a domain on the Freenom site and registered on the hosting here of InfinityFree and wanted to add the css certificate. I went in Cloudflare in the cpanel but gave an error when activating and even sent an email with a password to register me on the site. I registered and I followed a tutorial and I was able to activate the certificate css next to wordpress. Masa before I could get back here in the cloudflare in the cpanel and gave another error when I was activate and after I activated the css certificate still appears the same error. I wonder if that’s the way it is?

@Bruno-Braga said:
I created a domain on the Freenom site and registered on the hosting here of InfinityFree and wanted to add the css certificate. I went in Cloudflare in the cpanel but gave an error when activating and even sent an email with a password to register me on the site. I registered and I followed a tutorial and I was able to activate the certificate css next to wordpress. Masa before I could get back here in the cloudflare in the cpanel and gave another error when I was activate and after I activated the css certificate still appears the same error. I wonder if that’s the way it is?

Some correction:
It’s SSL Certificate not CSS Certificate

I think you should leave Cloudflare settings as it should be because it’s working fine on your site right?

I wrote wrong, it’s ssl. I’ll leave it as it is, it’s working fine for now. Now I want it is connected via FTP but I can not!