Insecure links

I noticed that if I type the name of a directory of my webpage, ( it takes me to all the folders. That way I can see all the files and pictures in that directory that should be private. I’m sure there is a way to stop this but I’m not sure how to. Please help.

What you’ve described is called directory indexing. To disable it, create a text file in your htdocs directory called .htaccess (or edit it if there’s already one) and add the following line:

Options -Indexes