Insecure connection

Sir I added SSL from cloudflare using automatic method. My site shows valid certificate but also shows connection to this site is insecure. because of this when I open my website my browser blocks some insecure and site does not open properly. my website is please help

If the images/stylesheets URLs are pointing to their HTTP version, use “Automatic HTTPS Rewrites” option on Cloudflare, it will rewrite all URLs with HTTP to their HTTPS ones.

You can use the Automatic HTTPS Rewrites like @Ergastolator1 said, but you can also fix it by updating your Website URL in the WordPress settings from to In my experience, configuring the backend software correctly tends to work better than magic rewrites.

As you said, after editing URL in the wordpress http to https my website is not opening. it says ERR_TOO_MANY_REDIRECTS. neither I am able to open wordpress dashboard now, what to now?

You need to remove the Always use HTTPS option if you have installed a Plugin that enables SSL or remove that Plugin if you want to not disable Always use HTTPS.

Sir I had disabled always use HTTPS option from cloudflare. But nothing happened, still the problem is same. I am unable to login to as well

Problem is solved. I had used the backup of wordpress.:grinning::grinning::grinning::grinning:

But still I am stuck at one place. connection is insecure after enabling https. you can check my website it is

Don’t use WordPress settings to change the domain from http to https, but try to enable “Automatic HTTPS Rewrites” option on Cloudflare.
Or try to change the SSL option from Flexible to Full.

1 Like

Thank you sir it worked. :smiley::smiley::smiley::smiley::smiley: Sir what does Full (strictly) means in cloudflare

Full (Strict) option is for use only with a valid certificate (not like the self-signed ones from this hosting). I recommend you to stick with the Full option.

Thanks it did the same

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.