I can't login to the hosting control panel

VP Login

The connection has timed out

Other Information

the website doesn’t direct me to anything when I click in “control panel” it keeps loading without getting to the page I tried many times and checked my connection, and it was perfect, and I tried 2 browsers seems like the problem is not from my device

I just checked the control panel for your account and it’s working perfectly fine (and pretty fast) for me.

Are you unable to access the control panel at all or just unable to login? What happens if you just try to access the login page at https://cpanel.epizy.com ?

If you tried different browsers on the same device, it only rules out the browser as being the cause of the issue. You can only know for sure it’s probably not your device if you experience the issue on multiple devices.

I don’t know how you checked your connection, but you being able to access other web pages or a speed test showing great results doesn’t mean that there isn’t a firewall in between that is blocking access to our control panel.


Could you please actually try a different device on a different network? So if you’ve been using your PC on your home network, then maybe try your phone on mobile network?

2 Likes

i did try 2 different devices and I can’t reach it out
i just want to enable FTP access to my account.

You have to login to the control panel to enable FTP access, and most functionality is only accessible through the control panel as well, so you really have to be able to access the control panel yourself.

Also two different networks?

Have you tried to login with a VPN instead?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.