Https connection

Username: epiz_26443725
Website: netbeast.ml
Error Message: ERR_SSL_PROTOCOL_ERROR

What I did and what I get:
I point my DNS to ns1 dot epizy dot com and ns2 dot epizy dot com. Then I use my cloudflare account and put my domain on that. Cloudflare got my DNS information and configure everything. So I change the DNS address to bella.ns.cloudflare.com and ethan.ns.cloudflare.com (as recommended by cloudflare), but, just http was working. If I try https, I got the error above.
So I remove my word press instalation and install it again using the https option on Cpanel, but got the same error.
I remove it again, install wordpress manualy using File Manager and set the adress to https:// netbeast dot ml. Same error.
I tryed to restore my DNS to the standard addresses (ns1 dot epizy dot com and ns2 dot epizy dot com) and configure cloudflare using Cpanel, but I got an error talking that my e-mail is in use on cloudflare, so I can’t go foward.
Now I’m using Cloudflare in the same way that I explaing above, and to continue using wordpress I change manualy the address to http:// netbeast dot ml.

Why I configure cloudfire manualy:
1 - The “email error” above;
2 - I would like to point the MX registry to my e-mail provider, and just can’t find an option to do this on Cpanel.

There is another solution to get https to my website and MX records pointing to my email provider?
Am I doing something wrong?

Thank you for any help.

PS1: I changed “.” by “dot” on my text becouse there are restrictions to new forum users.
PS2: English is my second language, so I’m sorry if I did some mistake on my text.

When i am visiting to your site it saying ssl handshake failed which ssl type you are using full or flexible if full then change to flexible (under the menu from ssl/tls)

Hi there.

Since you’re using Cloudflare to manage your DNS records, you can add MX record of your email providers by using Cloudflare as well.

For example, this is mine:

1 Like

Hey @anon84417008

This is probably happening because you haven’t installed a valid ssl certificate. If you have one on your hosting account change the ssl/tls encryption mode in cloudflare to full or if you don’t have one change it to flexible. “Full (Strict)” is not supported in free hosting as CA certificates are not supported.

Let me know if this helped.

4 Likes

Please note that nameserver changes can take up to 72 hours to take effect, and Cloudflare takes up to 24 hours to issue SSL certificates for free account. Both of those are reasons why switching to Cloudflare doesn’t immediately fix your website.

So you can just change your domain’s nameservers to Cloudflare and then wait a day or two before checking again.

4 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.