# Htaccess and index

**URL:** https://forum.infinityfree.com/t/htaccess-and-index/87759
**Category:** Hosting Support
**Created:** [December 21, 2023, 10:37pm UTC](https://forum.infinityfree.com/t/htaccess-and-index/87759 "2023-12-21T22:37:18Z")
**Posts on this page:** 1
**Showing post:** 15

<div class="post-metadata">

### Author: ![Admin](https://forum.infinityfree.com/user_avatar/forum.infinityfree.com/admin/32/36437_2.png) [@Admin](https://forum.infinityfree.com/u/Admin)
#### Post date: [December 29, 2023, 11:35am UTC](https://forum.infinityfree.com/t/htaccess-and-index/87759/15 "2023-12-29T11:35:46Z")

</div>

If you navigate directly to the View Source page, you won’t be able to see your page because you’ll be blocked by this security system:

> [@Ensuring only web browsers can access your website](https://forum.infinityfree.com/t/ensuring-only-web-browsers-can-access-your-website/49353):
>
> InfinityFree is a website hosting service. That means that the hosting accounts we provided are intended for hosting websites. Websites contain pages that are accessed through web browsers. InfinityFree is not intended to be used for file sharing, API hosting, database hosting or background tasks/tools. To help enforce this, free hosting enforces a security system that makes sure that anyone trying to access your website is using a normal web browser. This is done by checking whether the web br…

If you want to view the source of your page, you can simply navigate to your site first, then right click anywhere and then choose “View page source”.

However, the page source isn’t really interesting. Your site just returns a 500 status code with no page output. So the page source is just empty.

* * *

As for the issue itself, a HTTP ERROR 500 still means something is crashing. So please try enabling debug display / display errors again to get an actual error message:

> [@Htaccess and index](https://forum.infinityfree.com/t/htaccess-and-index/87759/7):
>
> I took a quick look at your site. I personally wouldn’t mess with the WordPress core files too much, but I don’t see any inherent issues in it. I did take a quick look in your wp-config.php to check if debug mode was on. It was on, but I also noticed these rules: // Disable display of errors and warnings define( 'WP\_DEBUG\_DISPLAY', false ); @ini\_set( 'display\_errors', 0 ); These rules specifically disable any errors from being displayed. That’s why you get the completely blank 500 error page.…

---

_[View the full topic](https://forum.infinityfree.com/t/htaccess-and-index/87759)._
