How to recover the default addon domain?

I deleted by mistake the default domain from DOMAINS > Addon Domains

photocall.epizy.com /home/vol3_3/epizy.com/epiz_00000000/htdocs

How to recover it?

I tried with “photocall.epizy.com” but I get the message: “This appears to be a subdomain you are adding (1008485) .”

Should be a button to restore it.

You can add free subdomains through the Subdomains menu in your cPanel. Yes, that menu is used both for subdomains of domain names you already have and our free subdomains.

@Admin said:
You can add free subdomains through the Subdomains menu in your cPanel. Yes, that menu is used both for subdomains of domain names you already have and our free subdomains.

Since I deleted “photocall.epizy.com /home/vol3_3/epizy.com/epiz_00000000/htdocs”
http://photocall.epizy.com it opens as “suspended” web.
I’m not able to generate /home/vol3_3/epizy.com/epiz_XXXXXXXX/htdocs
from DOMAINS > Addon Domains

Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

@Badchip said:
Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

Yes, if you delete the domain from an account the domain name will no longer show the website from that account. If you want the domain to show your website again, you need to add it back to your account.

You cannot point it back to the original htdocs directory, that’s a known issue. You’ll have to move your website files to the new folder.

@Admin said:

@Badchip said:
Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

Yes, if you delete the domain from an account the domain name will no longer show the website from that account. If you want the domain to show your website again, you need to add it back to your account.

You cannot point it back to the original htdocs directory, that’s a known issue. You’ll have to move your website files to the new folder.

I can’t open:

http://photocall.epizy.com/index.html
http://photocall.epizy.com/htdocs/index.html

@Badchip said:

@Admin said:

@Badchip said:
Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

Yes, if you delete the domain from an account the domain name will no longer show the website from that account. If you want the domain to show your website again, you need to add it back to your account.

You cannot point it back to the original htdocs directory, that’s a known issue. You’ll have to move your website files to the new folder.

I can’t open:

http://photocall.epizy.com/index.html
http://photocall.epizy.com/htdocs/index.html

The domain name photocall.epizy.com is currently not assigned to any account. You said you deleted it from your account, didn’t you? If so, you need to add it back through the Subdomains menu to be able to upload files to it.

1 Like

@Admin said:

@Badchip said:

@Admin said:

@Badchip said:
Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

Yes, if you delete the domain from an account the domain name will no longer show the website from that account. If you want the domain to show your website again, you need to add it back to your account.

You cannot point it back to the original htdocs directory, that’s a known issue. You’ll have to move your website files to the new folder.

I can’t open:

http://photocall.epizy.com/index.html
http://photocall.epizy.com/htdocs/index.html

The domain name photocall.epizy.com is currently not assigned to any account. You said you deleted it from your account, didn’t you? If so, you need to add it back through the Subdomains menu to be able to upload files to it.

Thank you. It was driving me crazy.
I think it would be a good idea disable/remove the “Delete” button of the default Addon Domain.

@Badchip said:

@Admin said:

@Badchip said:

@Admin said:

@Badchip said:
Create a new account, delete the default addon (from DOMAINS > Addon Domains)
and try to open the web. You will see what I mean.

Yes, if you delete the domain from an account the domain name will no longer show the website from that account. If you want the domain to show your website again, you need to add it back to your account.

You cannot point it back to the original htdocs directory, that’s a known issue. You’ll have to move your website files to the new folder.

I can’t open:

http://photocall.epizy.com/index.html
http://photocall.epizy.com/htdocs/index.html

The domain name photocall.epizy.com is currently not assigned to any account. You said you deleted it from your account, didn’t you? If so, you need to add it back through the Subdomains menu to be able to upload files to it.

Thank you. It was driving me crazy.
I think it would be a good idea disable/remove the “Delete” button of the default Addon Domain.

I agree that how it works now is not great.

However, if you’d ever want to host your current main domain on another hosting account, you would still need to delete it from the old account first. So there are cases where the delete button is useful.

@Admin how we can move this files in to another htdocs folder

@lalit_1106 using an ftp program. You can upload and transfer files using ftp protocol.