How to get rid of this error message in phpmailer


I have the following error message and just wondering if there is a way to get rid of it?

Warning : escapeshellcmd() has been disabled for security reasons in /home/pianocou/public_html/PHPMailer/PHPMailer.php on line 1632

Just add $mail->isSMTP(); on the signup file; I did it and it works, even on localhost or my AWS server.

1 Like

Nope… I still get this error and have tried the troubleshooting:

Mailer Error: SMTP connect() failed. Troubleshooting · PHPMailer/PHPMailer Wiki · GitHub

If you want to connect to Gmail’s SMTP, I highly suggest to try those parameters on your mailer file:
$mail->SMTPServer = "";
$mail->Port = 465;
$mail->SMTPSecure = "ssl";
$mail->SMTPAuth = true;
$mail->Username = "yourGmail";
$mail->Password = "*******";
where yourGmail can be overwritten with your Gmail email, and the asterisks can be overwritten with your Gmail password. But make sure you have enabled Less Secure Apps on the Google account settings and disabled the CAPTCHA request at login [click me]!

This is weird because I already had done that before… I think it is this version 6 issue… I have already disabled the CAPTCHA

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.