How can I disable automatic assign of Self-signed SSL cerificate?

I want to use my Cloudflare Flexible ssl, but when i assign it to this domain it will automatically assign the self-signed one, so users will have a warning message when they enter my website.

@pepyta said:
I want to use my Cloudflare Flexible ssl, but when i assign it to this domain it will automatically assign the self-signed one, so users will have a warning message when they enter my website.

If you use CloudFlare’s one then this will auto-disable and there will be no warning message.
But, DO NOT SELECT FLEXIBLE!
It breaks most websites, select Full instead, it will work better, and full works with self-signed.
Hope I helped :smiley:

I’ve tried with it already, but doesn’t work.

@pepyta said:
I’ve tried with it already, but doesn’t work.

How did you try? Please tell me, and also kindly provide URL so that I can check.

I went to the Crypto section and set SSL to FULL.
My website’s link is https://shoplist.ml

And the original site’s link is shoplist.rf.gd

@pepyta said:
I went to the Crypto section and set SSL to FULL.
My website’s link is https://shoplist.ml

Your site is currently offline, having an issue, otherwise SSL is working properly from my end, try to clear your browser’s cahce and tell me what happened. Your browser has cached the Old SSL, that is the reason why you are seeing as insecure while I see it as secure, you can see proof here:

That ??? thing means safe, sorry but I am Greek so I do not have English Chrome.

I tried it on mobilephone, Google Chrome, Mozilla and on Edge, but none of them could view the page via https.

The problem is still appearing.

Error code is:

  • MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT on Mozilla.
  • ERR_CERT_AUTHORITY_INVALID on Chrome
  • ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome Mobile

@pepyta said:
I tried it on mobilephone, Google Chrome, Mozilla and on Edge, but none of them could view the page via https.

The problem is still appearing.

Error code is:

  • MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT on Mozilla.
  • ERR_CERT_AUTHORITY_INVALID on Chrome
  • ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome Mobile

Don’t worry, it is looking safe for your clients.
Did you clear the cache as mentioned before?

@pepyta said:
I want to use my Cloudflare Flexible ssl, but when i assign it to this domain it will automatically assign the self-signed one, so users will have a warning message when they enter my website.

Flexible SSL means Cloudflare does SSL and then sets up an unencrypted connection with the backend server (your hosting account). In other words: no matter whether you have a valid certificate, an invalid certificate or no certificate at all on your hosting account, it could not possibly affect what your visitors see.

That said, all hosting accounts get a self-signed certificate by default, so you should always use Full SSL, not Flexible SSL (like @ChrisPAR already said). Flexible SSL is less secure and tends to give problems with URLs and redirects.

@pepyta said:
I tried it on mobilephone, Google Chrome, Mozilla and on Edge, but none of them could view the page via https.

The problem is still appearing.

Error code is:

  • MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT on Mozilla.
  • ERR_CERT_AUTHORITY_INVALID on Chrome
  • ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome Mobile

I think the issue is either:

  • Cloudflare has not finished setting up the SSL certificate for your domain (takes up to 24 hours).
  • Your nameserver changes have not propagated yet, so you are not visiting your website through Cloudflare (takes up to 72 hours).

@Admin said:
I think the issue is either:

  • Cloudflare has not finished setting up the SSL certificate for your domain (takes up to 24 hours).
  • Your nameserver changes have not propagated yet, so you are not visiting your website through Cloudflare (takes up to 72 hours).

Not exactly, as I said it shows perfectly from my end and it is CloudFlare’s SSL, he probably didn’t delete the cache.