Help with generating SSL Key/CSR

I go through the motions and after entering name etc. then clicking on GENERATE, nothing gets generated.

I’ve tried Firefox and Safari on my mac.

Any suggestions.

Please make sure you fill in ALL the fields in the form. If the field does not apply to you, enter something like NA in them, but all fields must be filled for the CSR generation to work.

OK - I’ll try that as I did leave department blank.

It works.

I’m back.

I got my SSL certificate and have pasted the text in, then clicked upload. How long before I know that its worked? If it hasn’t worked what have I done wrong?

@Mbenga said:
I’m back.

I got my SSL certificate and have pasted the text in, then clicked upload. How long before I know that its worked? If it hasn’t worked what have I done wrong?

It will need some time, probably 1 hour or more to know if this worked.
If it didn’t, just say it here, and even @Admin will be able to fix it, if it’s a problem, otherwise contact the SSL Issuer.

@Mbenga said:
I’m back.

I got my SSL certificate and have pasted the text in, then clicked upload. How long before I know that its worked? If it hasn’t worked what have I done wrong?

What error did you see on browsers?

The SSL certificate is installed almost instantly. However, most browsers cache certificates for a while, so it might take some time to show up. Which is why the knowledge base recommends using an SSL checker: https://infinityfree.net/support/how-to-install-an-ssl-certificate/

I’m not sure if my certificate is working right. If I type the address with https in it the padlock shows - but if I don’t type that then no padlock.

@Mbenga said:
I’m not sure if my certificate is working right. If I type the address with https in it the padlock shows - but if I don’t type that then no padlock.

You can force your site with ssl without typing the https next to your domain.
Insert the code on your .htaccess

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Thanks - I’ll try that.

Yipee!.

@Mbenga said:
Yipee!.

So your problem is now solved!
I’m glad.