Help! I get a 403 error!

Ok, the site I am managing is constantly giving me 403 errors, Its only me getting the errors, basically on only my IP address, Its getting so hard to test my site, because I’m running out of devices to test it with! I am told this is my hosting provider blocking my IP or something. @admin, why is this happening, am I doing something wrong?
Help! Thanks!

Actually, I just tried connecting to the site via VPN, and the 403 error is still there!
Site: https://REMOVED.com
Problem Page: removed.com - Informationen zum Thema removed.
Problem Page: removed.com - Informationen zum Thema removed.
Those are just 2 pages, I’m sure there were more.
Thanks for any help!
Greenreader9

Most likely this is a htaccess issue. Please can you share your .htaccess code?

2 Likes

Where do you see the 403 errors? I don’t see any errors like that. Can you please take a screenshot of what you see?

These two pages are returning the 403 error.

1 Like

Ah, thank you, I didn’t read correctly apparently.

My first guess is also a .htaccess issue. The first thing that caught my eye about your .htaccess file is that you have the line RewriteEngine On four times in your .htaccess file. Note that every time you use this line, it removes any previously defined rules. So normally, you only want to add this line once at the top of your file, and then just add rewrite rules below.

1 Like

Ok, I will try fixing this later and let you know the result! Do you think this is the cause for all the issues? Also, does it make sense to have the same .htaccess files in multiple directories (/htdocs & /htdocs/Products & /htdocs/Contact), or is that just me trying a bunch of random stuff to try and fix this? (I guess what I mean is does the .htaccess in the root folder affect all of the other folders?)
Thanks!

Honestly, I’m not sure. I don’t see anything that is an obvious cause for 403 errors. But I know that having rewrite rules that are not being applied due to overwriting them with the next rule block is probably a source of unintended behavior, so it doesn’t hurt to start there.

Yes, a .htaccess file affects all subfolders too. Unless you specifically override the configuration in the subfolder, of course.

This is actually how our default .htaccess file can apply to all your sites, and you can overwrite them with your own .htaccess file.

1 Like

I tried removing all but the .htaccess in the root folder, I still get 403 on VPN and inPrivate mode. Is something else messed up?
Thanks!

Ok, this is getting really annoying now. Anytime I upload a new page, 403. Edit a page? 403. Reload a page multiple times? 403. Delete files and re-upload? 403.
Does anyone know why this is happening? Thanks!

What is messed up is that you don’t actually own this site. It’s part of a different client area profile. Your main profile already has three accounts.

Please remember that you are only allowed to have three accounts per PERSON. Creating multiple profiles with different email addresses to create more than three hosting accounts is a violation of our terms and grounds for termination of all your accounts. If you need many websites, please consider using addon domains on your existing accounts or getting a reseller hosting account.

As for the website itself, even disabling the .htaccess entirely doesn’t remove the redirects.

But I also see you’re using Cloudflare. And your website seems to behave differently when accessed directly. Can you please double check that the website is actually being served from our hosting and not from somewhere else?

3 Likes

I forget if I mentioned this in the beginning, but this site is not mine, it’s a friends. She wants all of this stuff under her email (otherwise I would have deleted one of my websites and put hers there instead.) She provides the content for the site, and I upload and configure everything.

Are you referring to IP address and name serves here? Does this mean I need to create a new A record with a different IP?

Thanks!

OK, that makes sense.

I don’t know. You’re using Cloudflare, which hides the IP address which is actually serving your website. And as far as I can tell, the website may not be served from our hosting given the different behavior.

It’s your responsibility to make sure the DNS is correct. I can’t even tell if it is.

Can I show the IP address or is that not safe? Also, I triple-checked, and the IP in the top two lines are the same as below.

Is something in the first image messed up?

No, that DNS looks OK.

There isn’t much point in censoring the IP addresses though. By setting Cloudflare to “DNS Only”, everyone in the world can see the IP address. With Cloudflare enabled, anyone who knows you host the website with us can also fairly easily find your IP address.


One of the things I noticed that removed.com - Informationen zum Thema removed. does not work, but removed.com - Informationen zum Thema removed. does work, and redirects me to removed.com - Informationen zum Thema removed., which also works.


Looking at the .htaccess rules again, I think these rules are the culprit:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([^.]+)$ $1.html [NC,L]

What this does is check if the file name exists, and if it doesn’t rewrite it to something with .html.

So when you navigate to removed.com - Informationen zum Thema removed., it checks if there is a file called Products.html in the main htdocs folder. Since there isn’t one, it goes to the RewriteRule, which rewrites it to Products.html anyways??? I think, .htaccess rules are hard to read.

Looking at the rules below, there are six different rule blocks which are sort-of related to stripping file extensions like .html or .php from URLs. Am I correct to assume that you’ve tried different example snippets to do that?

Next time, if you are trying different snippets and some of them don’t work, then please make sure to remove them before trying something else. Leaving broken code in a site can cause all sorts of problem, and I think this is one.

6 Likes

So right!

I didn’t even think to try that!

Yep.

Your right, sorry for this, I totally did not even think to complete re-do my .htaccess file. I removed all of those snippets, added two new ones, cleared my cache, and boom, it works.
Thanks so much for finding that little dumb error of mine!!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.