[HELP] Error: "You do not have permission to create a subdomain on this domain"

I added a custom domain which is totally working fine. Wanted to add a subdomain for my custom domain but received this error: “You do not have permission to create a subdomain on this domain”.

After searching through this forum, I realized there are certain subdomains like ‘mail’ which are reserved. I confirm that I tried registering some random names like hello78 with no luck. Also, creating a subdomain with the infinityfreeapp.com domain also throws exactly the same error.

Please help me resolve this.
Thanks in advance.

Can you please share an error screen/message, like what does it say?


Just this

@HaydenANG You can try to reproduce this by adding a ‘infinityfreeapp.com’ subdomain. It gives exactly the same error for that domain.

As you can see;


I appear to be getting the error as well, this might be a mis-configuration, so the best we can do is wait.

@HaydenANG Thanks for confirming. Yes, it seems to be a misconfiguration. Let’s wait.

I’ll contact IFastNet (The sponsors of InfinityFree) and see if anything is up

@HaydenANG Thanks a lot man. Waiting patiently.

Yeah, But what’s weird, Is on some domains/subdomains I can create a subdomain, and I don’t get the error, whereas on some I do get the error

For anyone who Is getting an error when creating a subdomain, the reason is a known bug/issue, you may get an error like;

But IFastNet have said;

Hi there,
We are aware of this issue, kindly check again later today or tomorrow.
Thank you and stay safe !
Please let us know if there is anything we can do.

So the best we can do is wait, However you should note that this does change, and some domains are uneffected.

2 Likes

Fixed for me. Thanks a lot @HaydenANG

No problem :slight_smile: I’m here to help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.