Getting '404 Page Not Found' error after enabling Cloudflare

This is not a problem due to my browser as returns the same result.

Cloudflare says this is a problem server’s end.

Hello there,

What’s your site URL?

Note that the error does not show on the homepage. It shows on post pages.

I did check some of your post like this one:
And it returns to an error 404 indeed.

This could be a permalinks issue which is quite common in WordPress.
Can you try the following:

  1. Go to your WordPress dashboard
  2. Go to Settings/Permalinks
  3. Then just click the save button

Thanks a lot that worked like charm!

1 Like

You’re welcome! This is a very common issue I always encountered when using WordPress.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.