G Suite Account MX Is Not Working



I have created an account in G Suite and added those MX records to the control panel. But when I am trying to activate it is showing “Missing Error”

Please do needful.

Hi there,

You have combined both epizy and byet nameservers!
Please remove byet nameservers(They are not reliable)


OK I have deleted those Nameservers and will take some time to propagate. Now means that google MX will work right.

After the propagation. Delete the old mx records and re add them

1 Like

Your domain name is using our Cloudflare integration, which breaks many things, including MX records.

Please disable our Cloudflare integration on your domain name, or sign up with Cloudflare yourself and use Cloudflare’s nameservers.


Thanks for your support. But after updating the Cloudflare Name Server SSL is not working on the website.

1 Like

Try deleting the mx.epizy.com MX entry


AFAIK Cloudflare takes up to 24 hours to issue SSL certificates on free accounts.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.