Error adding domain

epiz_25916752 (

Error adding domain, This could be due to already adding the domain to this or another account or, you have not changed the nameservers as required or not enough time has passed since changing the nameservers…

The NSs have been added correctly in my DNS (cloudflare) 60 hours ago, as shown in the attached images. Is there an additional step I haven’t taken? I appreciate all the information and help you can give me.

Try using fresh install/setup of your domain.

You are using namecheap, then remove those DNS records first using cloudfare and change your nameservers back to & using namecheap, and wait for a few hours.


You mean to add and ns2… In namecheap instead of Cloudflare?

1 Like

Yes, exactly!

Remove first your domain on Cloudfare including those DNS records (CNAME, A, MX) then change your nameservers to ns1 and ns2.

And wait about 30 minutes or 2 hours or a day before changing to Cloudfare again.

Is this what you mean? I placed Epizy’s ns directly on Namecheap

1 Like

No, you have to set them as nameservers and not as NS records! To do that please follow this article.


you’re right, it was my mistake of not reading well in namecheap. is already registered in epizy. now I need A records to be able to add it to cloudflare … can you help me? i couldn’t find such A REG in my epizy cpanel

You don’t need to add an A record to setup for Cloudfare SSL. Just change your nameservers to ns1 and ns2, and wait for an hour or a day before changing to Cloudflare nameservers again. Because if you will change your nameservers to Cloudflare just after you add the Infinityfree nameservers, your domain will not work, and you would get a DNX error. This happened to me last time, I immediately change my nameservers to Cloudfare nameserver, and I got an error.

1 Like

It worked perfectly.

Now I am waiting for the SSL certificate, I attach a screenshot in case there is an error. Grateful for all your help.

1 Like

Glad to help!

But can you remove the two NS record and the two CNAME Record (acmechallenge). Because its no need. You are now using cloudfare so you will not need that CNAME record.

I assume that you have already set your nameservers to cloudfare nameserver and please be note that it takes an hour or a day to activate your SSL.



I’m trying to visit your website, but I got a SSL Handshake failed error so I couldn’t get or view into it. Kindly change your SSL/TLS mode from Full to Flexible. You can find it on your Cloudfare Dashboard, then clear your browser caches after.

It is because you are using cloudfare certificate not your own.

I’ve updated you here, just incase if you will get this same error in the future or maybe tomorrow.


Thanks a lot, it’s already solved. Yes, I had not modified more Cloudflare options before SSL …

What do you mean? If it’s putting Cloudflare nameservers in Namecheap (my domain registration), yes. They are updated after having followed your previous recommendation.

Yes, sorry, nevermind it. You’re doing great!

For now change your SSL/TLS mode to Flexible, like what I have said above. Thanks!

I could now see your site, however its not a fully secure. Check and enable the Always HTTPS and HTTP Rewrite on Cloudfare SSL/TLS Settings.

Because not ssl certificate…


You know what really bothers me about all this? Having so many inconveniences to install or update plugins … If I upload them via FTP they work, but many cannot be installed directly. And it is something of the hosting.

I couldn’t understand your language, I’m sorry.

You know, having too many plugins and run on the same time can cause Cpu limit failure. You could try to install a plugin called W3 Total Cache, this could help you to minify your html,javascript,css and clear your page caches.

And please be aware that you can only upload plugin files not bigger than 10MB.

Regarding the SSL certificate … These records that I show you in the image, should be uploaded to or cpanel epizy in the CNAME section? I emphasize that dash,cloudflare,com is targeted at namecheap,com (dara and sri ns,cloudflare,com)

So they are added in