Error 500 message after trying to update wordpress

Hi, I cannot access my website after trying to update to the latest version of wordpress. The site was previously 4.03. After ages sitting in maintenance mode the site now gives me an error 500 message. Not sure what to do!
Thanks,
Dan

I am receiving this message: Cannot redeclare get_shortcut_link() (previously declared in /home/vol2_3/rf.gd/rfgd_20280267/htdocs/wp-includes/link-template.php:2906) in /home/vol2_3/rf.gd/rfgd_20280267/htdocs/wp-includes/deprecated.php on line 3912

I assume the update was incomplete or dropped out?

@proart said:
I am receiving this message: Cannot redeclare get_shortcut_link() (previously declared in /home/vol2_3/rf.gd/rfgd_20280267/htdocs/wp-includes/link-template.php:2906) in /home/vol2_3/rf.gd/rfgd_20280267/htdocs/wp-includes/deprecated.php on line 3912

I assume the update was incomplete or dropped out?

That’s likely, yes. To fix this, you can download a fresh copy of WordPress, extract it on your computer and then upload it to your hosting account on top of your existing website (overwriting any files as you go). That should fix any corrupted code.