Error 403 on my website, don't know how to fix

I am trying to run a test website with just one index.html and one css document, but every time I try to load it, it gives me error 403 Forbidden. I have no idea what could cause this, as I did nothing in the file manager except upload the files and delete the original index2 file, which also could not be accessed. I did not tamper with .htaccess either, it is the htaccess that came with the server. Could anyone help me figure out what’s wrong?

Username (e.g. epiz_XXX) or Website URL

daveyloper.com

Error Message

Error 403

Other Information

Maybe moving your files to daveyloper.com > htdocs folder can fix it?

2 Likes

I did upload the files to htdocs, no subfolders or anything.

I’m also wondering if it could be an issue from cloudflare, as that’s where I got the SSL certificate, but I’m not sure about that. I used an SSL checker and my SSL seems to be working correctly, and I don’t get the error for that anymore. Now I only get the 403 error.

can you please do what i wrote?

Your domain is not showing the default 403 Forbidden page which InfinityFree has, so it’s not pointing to our servers. Please make sure that your domain is pointing to our servers by pointing all A records for @ and www to the IP address of your hosting account, which can be found on the Account Details section of the Client Area on the hosting account’s page, through Cloudflare’s dashboard.

Okay, I tried this. I went to cloudflare’s DNS management and changed the IP addresses of @ and www to the one on my account details page. Now I’m getting an SSL handshake failed error (525), however.

Did I do the right thing here?

Do you mean creating a new directory in the root folder named “daveyloper.com” and creating an htdocs folder inside that? I do not see a directory named “daveyloper.com” anywhere. If I sound like an idiot, I am, cause this is the first time I’ve worked with hosting a website, so I apologise.

You will then need to set the SSL option to Flexible, as our servers by default don’t have a certificate installed.

Oh yes, doing what you said above and setting the SSL to flexible worked… Thanks a lot!

1 Like

Now your website is working from my end

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.