ERR_TOO_MANY_REDIRECTS after managing redirects in control p

Hi!

My domain is: dianacristinailiescu.com
I installed my SSL certificate, then updated my .htaccess file with the code provided from you which is:

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} =http
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

then I redirected my domain to https://dianacristinailiescu.com from cPanel

and I’m getting this error when trying to on my site:

This page isn’t working

domain redirected you too many times.

Try clearing your cookies

ERR_TOO_MANY_REDIRECTS

Yes, I did clear all the cookies and yes, my .htaccess file is in the htdocs directory

It seems that after I add the redirect link in cPanel, I get this error.

Please, help! :frowning:

Thank you,
Diana

You need to remove the redirect from the redirect tool, because the redirect tool is only useful if you need to redirect to another domain and not the same domain.

4 Likes

I just did, but I still get the same error. After I delete the code in my htaccess it goes away, but then my site is not sure. :frowning:

What can I do? Thank you for being responsive :smiley:

Since you’re using Cloudflare it’s better to remove all redirect codes from your htaccess file and use the “Always Use HTTPS” option of the “SSL/TLS” section of the Cloudflare dashboard for your domain.

5 Likes

Sorry for this interruption and I also think that you use Cloudfare SSL/TLS Full Mode, better make it to Flexible Mode. That’s happened to me back then when I did use the Full Mode.

secure*

I enabled Cloudflare, but I’m not sure why. I have no clue what to use it for haha. I disabled it in cPanel. Do you think that will do?

Yes, it did the trick, and now the redirect works fine.

I still get the too many redirects error on my browser. When my friend is trying to go on it, it works, but it’s not secure. :confused:

May I interrupt? Sorry.

What mode are you using? Full mode or Flexible Mode? Locate it on Cloudfare > yourdomain > SSL/TLS.

Nevermind, I only had to close my browser and open it again. It works fine now! Thank you for being so responsive!

@katufo I have no clue, I didn’t change any settings in Cloudflare, but I’m all good now. Thanks!

Good to know. Kindly mark Ergastolator1 answer as the solution ;D.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.