I have already generated SSL using infinityfree SSL tool , issued, and uploaded Private Key and Certificate. But when I entered the site(using https), it showed this error “ERR_SSL_PROTOCOL_ERROR”.

My Website:
Browser: both Edge and Chrome not work

It is working for me. You need to clear your cache.

1 Like

use Cloudflare, set to Flexible wait for 1 day or more and it will automatically fix and add Lets Encrypt. Then install Cloudflare plugin on Wordpress if you use wordpress (You can access website admin via Samsung Internet default browser)

It’s not working for me.
I have also used browsing in private, and it did not work.

use Samsung Internet browser if you have Samsung phone. it work fine there

and connect your website to Cloudflare set SSL mode to Flexible and wait for few days. it will automatically fix.

But not work for me, is that because of the country difference?

@R0ot3dDr0id, The site is working fine with SSL, Cloudflare is not required to solve this. It is a cache issue. Your phone works because it has not cached the site yet, not because it is a Samsung.

@huacat1017, note that your ISP may also cache the site. Use a cellular device on a cellular network (And clear is cache first as well), or use a different internet.

Use another network… SOLVED(Thank you!)
But it was slowly then before.
And how to go to the website with my original network?

OK. It’s working now on my original internet. Just restart my device and wait for a moment.

The problem is back!
How to clear the ssh cache in my Internet Provider?(I have tried to clear browser / SSH cache in my computer)
I have to use a new network or a new computer to solve that problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.