ERR_SSL_PROTOCOL_ERROR, my website are like broken

I used a plugin, which called Https rewriter. For my wordpress website.
After I turned it on and turned the setting on, the website just showed this issue.
I’ve removed the plugin and got the same problem.

I am not sure what to do.

You need an SSL certificate.

Well, then you will have to wait if you configured it correctly in this article.
https://infinityfree.net/support/how-to-install-an-ssl-certificate/

The SSL works on my Main Domain.
But my Sub-domain still have got the problem.

Well, if you tried using the free SSL certificates, it should have said that it didn’t support subdomains.

Does cloudflare support that?

What did you enter for the cloudflare details?
And did you wait long enough for cloudflare to detect it?
If you try adding subdomains to your account (unless you use enterprise) cloudflare says you can’t add it. I already tried.

That’s completely normal. The SSL certificates we provide are only valid for example.com and www.example.com. They are not valid for blog.example.com, forum.example.com or any other subdomain of example.com.

Even though we could technically give you certificates for subdomains, the free hosting control panel doesn’t let you install SSL certificates on subdomains.

I think your best option is to use Cloudflare Flexible SSL instead, which can just connect to your website without requiring SSL on the hosting server.

3 Likes

ME still Getting the error too
ERR_SSL_PROTOCOL_ERROR

Perhaps because your ssl is expired?

1 Like

@Michaelpopoola

please open a new topic (hosting support)
and answers to the questions contained in the template
Thank you

3 Likes