cURL error 35

Username ( epiz_25856987 ) or Website URL :- techgs.xyz

(please specify the website or account you are asking about)

Error Message

Error: cURL error 35: Peer reports it experienced an internal error. (http_request_failed)

(please share the FULL error message you see)

Other Information

I see this error in wordpress site health

(other information and details relevant to your question)

Please help me what can i do now?

Thank you

Some reasons why you’re facing the problem/issue:

  1. Outdated curl
  2. You didn’t configure cloudflare ssl https well

I am also facing this problem back then, and what I only did to fix is to have a origin certificate on infinityfree server before enabling cloudflare on my site and with using Full mode on cloudflare SSL/TLS.

4 Likes

Thank you i will try this

I added cname records for infinity free ssl certificate in cloud flare its work or not?
Thank you

It will work as long as you configured the cname correctly. The two cname records. And also make sure that you have also change your nameservers into cloudflare nameservers too!

2 Likes

Yup i changed already and i using cloud flare ssl certificate…when i get ssl certificate from infinity free i will upload to cloud flare
Thank you again :slightly_smiling_face:

Upload it on SSL/TLS on infinityfree control panel, wait for an hour or minutes and then enable full mode on cloudflare dashboard.

2 Likes

It has been 24 hours, cname has not been updated yet.

What do you mean? May I see the error message the you got? Screenshots?

See

Sorry but I couldn’t find any of CNAME records on your domain, I used CNAME Lookup.

I want to know where did you trying to add a CNAME records? Through InfinityFree cpanel or cloudflare?

Please add the required CNAME using Cloudflare DNS manager, since you are using Cloudflare nameservers.

dash.cloudflare.com

2 Likes

I added cname records in cloud flare

May I see a screenshot of the record on cloudflare?

When did u put the cname record?

Also, can you uncheck that Proxied and may it gray and wait for an hour or day to recheck the DNS status? That might work.

5 Likes

I have done 25 hours by adding cname i try unchecking the proxied
Thanks

My ssl is ready, now where I have to upload that one in hosting or cloud?

On hosting infinityfree.

Navigate to Control panel > SSL/TLS > Upload the certificate and private key that was given to you by the client area.

3 Likes

Hyy i uploaded… What about csr?.. What next?

Hyy i checked my wordpress site health its good thank you thank you soo much rest api problem solved and other problems also solved thank you so much
Cloud flare proxied is uncheck can i check the proxied or not?
Thanks again :slightly_smiling_face: