Cloudflare subdomain SSL - Error 525

Good afternoon friend

I’m having trouble accessing my subdomain.

https://curriculum.nunes.link/

The base domain https://nunes.link/ is normally used SLL access. Now the subdomain I created is triggering the Error below:

The settings in CloudFlare have already been made

can anybody help me?

Sorry if I misspell, I’m from Brazil :brazil:

1 Like

IT has nothing to do with DNS. Go to SSL/ TLS tab and set it to flexible.

5 Likes

It was set to Complete. I will make the changes.

Sorry to bother you, I’m new to the subject.

Problem solved. Thanks

3 Likes

No problem!

4 Likes

If you want to use full mode, then install a certificate on the subdomain

1 Like

Make sure is full mode, not full(strict)

5 Likes

If you have valid certs for your domain and subdomains (including let’s encrypt), you can set it to full strict without problems

1 Like

Nope, you are wrong.

Pls read carefully…

3 Likes

Yes… I was unsure so i didn’t respond :sweat_smile:

2 Likes

lets encrypt and go get ssl from the free ssl tool are trusted CAs. If you have installed a free ssl cert from the free ssl tool, then you can enable full strict:

2 Likes

See

1 Like

Interesting. I believe these are self-signed. Did you generate the CSR(s) for your domain(s)/subdomain(s)?

3 Likes

They aren’t self signed. the root ca is trusted by all major browsers:

You don’t need to. Just upload the private key and certificate and cloudflare will trust it.

2 Likes

Gr8! At least I learnt something today. Previously was not able to utilise the full(strict) mode. 10q @Dev-I-J

4 Likes

Glad it helped :grinning_face_with_smiling_eyes:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.