Cloudflare Issues

How would I enable Cloudflare SSL for my subdomains since it only works on my normal domain? The subdomains are created with Infinityfree but I dont know how to make them proxy through Cloudflare with SSL.

I am also having the issue where I get the error of SSL handshake failed. Cloudflare Support says it might be something on the origin server.

What you selected in ssl mode full or flexible?

Full, it was previously changed to Flexible by Cliudflare but I changed it back to Full

Change to flexible

3 Likes

And did you added your subdomain cname in cloudflare

How would I do that? I add the subdomain through InfinityFree but it still comes up saying “script.nodeapps.cf’s server IP address could not be found”

Add cname record and in nane put your subdomain and in target put your main domain example:-

In name put sites
In target put google.com

Hello @TehN3on!

You need to change your SSL Mode from “Full” to “Flexible” as a workaround to this problem. So you can’t activate “Full” mode since so dont have any origin SSL certificate. Flexible mode works with no problem.


  1. Open your CloudFlare dashboard and navigate to your site panel.

  2. Then, click on “DNS”. Click “Add Record”.

  3. Change the “Type” to “CNAME”.

  4. Now, you will see 3 inputs.

  • Name section - stands for the subdomain name you want to add. Type the subdomain you want to add. (sub.example.com)

  • Target section - your website’s domain name. Type your website’s main domain name (example.com)

  • TTL - leave this option.

  1. Then click “Save”.

After that, you will need to wait for hours to make changes effect worldwide.

I hope it helps :slightly_smiling_face:!

7 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.