Cloudfare SSL not working

My website URL is:

What I’m seeing is:
not connecting to host

I’m using this software:

I am using mybb

Additional information:

I have added to htaccess:

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} =http
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI

I have set up cloudfare; ( it does not allow me to add ssl certificate for cloudfare in control panel )

Initially; this came back good, but now its no good.
current: 7d13c297-68b2-4911-a509-23a1bf467db3

Not sure whats going on. Some help would be appreciated. Thanks!

That is rather odd. It might be a problem with the DDOS protection. The handshake is not working properly; but the certificate stays until it tries to access your site. I am receiving an Error 525 SSL handshake failed.

1 Like

Any ideas for a solution would be appreciated. I stubbornly tried to figure it out myself for 2 days now… I need help.

I would try to temporarily disable the DDOS protection; to see if that is the problem. Otherwise, it is a problem with the certificate being issued by the authority.

The main cause is a configuration issue.

1 Like

New to infinityfree; how would i go about?

  1. Make sure you have a valid SSL certificate installed on your origin server.
  2. Check with your hosting provider to make sure they’re listening on port 443.
  3. Check to make sure your origin server is properly configured for SNI .

I think my issue isn’t with cloudfare configuration; but my configuration with infinityfree.

It will take the Admin or an InfinityFree staff to look into it further. In the meantime, you can make a backup and try uploading a basic index.html or index.php file. To see if it completes the handshake or not.

1 Like

Ah yes, the typical error.

If you head to the Cloudflare Control Panel, under Crypto/SSL you will see different SSL modes, these include None, Flexible, Full or Full (strict). Full & Full (strict) will not work with the free hosting platform. Switch the setting the flexible and the issue will resolve itself. @h4xr0x


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.