Can't Validate SSL Certificate

My website name is: https://blog-in.gr

I have added a Let’s Encrypt SSL to this site, through the free process from Infinity Free dashboard. Whenever I visit my website, everything works fine and SSL is working correctly.

But the problem occurs when I use Facebook’s debug tool, where I get this warning: “Can’t validate SSL Certificate. Either it is self-signed (which will cause browser warnings) or it is invalid.”.
I can post or send the link through Facebook, but when I try to add a photo to show up with the link (for example with Yoast SEO), it just shows the link without anything else.

How can I fix both of the problems (I think they are related)?

Thank you for your time and I’m sorry if I ask basic questions.

You can add your domain to https://dash.cloudflare.com/login

I found this solution too. The only thing I considered was that nameservers (from the domain’s dashboard) are pointing to InifityFree’s nameservers. If I change them, as Cloudflare needs, does it have any effect?

And one final question, if I do this, I can solve the “image” problem?

Thank you for your answer!

If I change them, as Cloudflare needs, does it have any effect?

CloudFlare shd auto-detect your A or CNAME record. If not, you can add in manually.

And one final question, if I do this, I can solve the “image” problem?

What image problem?

1 Like

I am using Yoast SEO to add images, so they show up when I post the link of my site to Facebook. The image isn’t showed and in Facebook’s debug tool, I have this problem with SSL. Is this the “main” problem for not showing the image?

I really dun get you. Can you show with some illustration?

The main problem is that our free hosting doesn’t support uploading so-called CA chains along with the SSL certificate. Most browsers work fine without CA chains, but many automated tools can’t validate the SSL certificate without them.

Cloudflare does install CA chains on their edge sites, so that’s a good workaround. If you don’t want to go that route, switching to premium hosting would also allow you to fix it (on premium hosting the Let’s Encrypt management is completely automatic and includes the CA chains).

3 Likes

Thank you very much for your reply!

I want to add one more question if I’m not tiring you. I want when I send a link from my site (e.g. a new page) to be shown an image with the link. For example, when I post “https://google.com” it comes up with a photo, like thisCapture .

I searched online and I found a solution with Yoast SEO (plugin for WordPress). It turns out, even when I do the right settings, that no picture shows with my link.

Any idea why this happens and how should I fix it? (My site is: https://blog-in.gr)

That’s caused by a security system on free hosting:

As with the last issue: using either Cloudflare or premium hosting fixes this.

3 Likes

Thank you very much for your replies and your time!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.