Can't delete email forwarder - "Destination address contains illegal characters..

Can’t delete email forwarder - “Destination address contains illegal characters please report this to support 1”

I have tried setting a forward to my personal email at Gmail, using the +feature. So the forward email looks something like this [email protected]

Then I learned you can’t forward to Gmail. When I was going to delete the forward it won’t let me, displaying the above error message.

Please help :slight_smile:

@ForumUser-epiz_21996481 said:
How do you contact support directly when CPanel tells you to do so?

I can’t use my main email currently and it’s a real problem.

Cheers

Here, this is where you get support.
And also what’s the email problem your experiencing?

Hi @UnknownLolz , please see this post to understand my problem: https://forum.infinityfree.com/discussion/3847/cant-delete-email-forwarder-destination-address-contains-illegal-characters#latest

When I had to change the DNS settings on my domain I lost my email setup, so need the Infinity one to work. Unfortunately it won’t let me delete the email forward I have created so I can’t get my main email working again, which is out there and many people know and contact me over it.

@ForumUser-epiz_21996481 said:
Hi @UnknownLolz , please see this post to understand my problem: https://forum.infinityfree.com/discussion/3847/cant-delete-email-forwarder-destination-address-contains-illegal-characters#latest

When I had to change the DNS settings on my domain I lost my email setup, so need the Infinity one to work. Unfortunately it won’t let me delete the email forward I have created so I can’t get my main email working again, which is out there and many people know and contact me over it.

Can I see the screenshot of the error and the screenshot of your configuration in the email forwarding settings?

@UnknownLolz Here is the forward setup:

Please note that I have set the MX record and the email “[email protected]” works as it should

Here is the error I get when I try to delete the email “[email protected]

@ForumUser-epiz_21996481 said:
@UnknownLolz Here is the forward setup:

Please note that I have set the MX record and the email “[email protected]” works as it should

Here is the error I get when I try to delete the email “[email protected]

As I see, your destination address for your email has a + sign and that is not acceptable on cpanel, which means cpanel will reject your request.
And also I am surprised that you managed to add a +,

I think I have a solution, I’m not sure if this will work.
Delete you [email protected] and create a new [email protected].
I think this because once you delete your email it doesn’t exist anymore which I think will also delete the forwarding settings too.

@UnknownLolz

Yeah, it got in with the plus sign, alright. Just won’t get out again :slight_smile:

I looked under Email Accounts but it’s not listed there. The only place I can find where the info email is listed is in the Forwarders menu. And I can’t create it here either, as it says it’s already listed as a forwarder.

Where else should I look in order to delete the email?

See, Email Accounts is empty:

@UnknownLolz Any more ideas? Only other option I can think of at this stage is to change hoster and move the website :frowning:

@ForumUser-epiz_21996481
I am not pretty sure if I have any other idea but I need to do a little of a research about your problem.

@ForumUser-epiz_21996481 said:
@UnknownLolz Any more ideas? Only other option I can think of at this stage is to change hoster and move the website :frowning:

BTW are you using Cloudflare?

@ForumUser-epiz_21996481 said:
@UnknownLolz Any more ideas? Only other option I can think of at this stage is to change hoster and move the website :frowning:

I have another solution for you,
Once you answer my only question, Are you using Cloudflare?
Once you answer this question I can help you.

@UnknownLolz said:

@ForumUser-epiz_21996481 said:
@UnknownLolz Any more ideas? Only other option I can think of at this stage is to change hoster and move the website :frowning:

I have another solution for you,
Once you answer my only question, Are you using Cloudflare?
Once you answer this question I can help you.

I’m pretty sure his is not using Cloudflare because his IP is 185.27.134.131 not a part of Cloudflare giant network the IP is a part of iFastNet Ltd. Now you can tell him the solution!

@UnknownLolz No, cloudflare is not enabled.

Other idea: Can’t you guys just go in the backend and remove the forward in the database that feeds CPanel, or just remove the “+” sign?

@ForumUser-epiz_21996481
Hey, don’t lose hope on InfinityFree just yet,
First of all this is a very common solution which is used by many InfinityFree users.

The solution is that you’ll have to use an external email provider.
“Also sorry if this is not elaborately explained”
First: Go to Zoho or Yandex
Second: Verify your domain.
Third: Change your MX record to what Zoho and Yandex tell you.
Zoho = mx.zoho.com and mx2.xzoho.com and yandex is mx.yandex.net
Fourth: Test your email for sending and receiving.

And also this will help cause when you change your mx record it will ignore the forwarder setting that you made on the cpanel cause the mx is not set to InfinityFree’s.

Hope this works.

@ForumUser-epiz_21996481
There is also a bonus.
They encrypt your email with TLS the Transport Layer Security and which is the successor over SSL.

And also I choose those two provider above because they are free and everybody loves free, am I right?

@UnknownLolz

Thanks for the workaround. Not sure this is what I had in mind when I asked for help, but should indeed work.

@UnknownLolz On another interesting note, I have just seen that the non-working forwarder no longer exists… Has it deleted itself, or has someone made a change in the CPanel backend?

Anyways, halfway through of moving it to Zoho…

@ForumUser-epiz_21996481 said:
@UnknownLolz On another interesting note, I have just seen that the non-working forwarder no longer exists… Has it deleted itself, or has someone made a change in the CPanel backend?

Anyways, halfway through of moving it to Zoho…

What!?
Oh maybe it just takes the cpanel time to refresh the stats.

@ForumUser-epiz_21996481 said:
@UnknownLolz On another interesting note, I have just seen that the non-working forwarder no longer exists… Has it deleted itself, or has someone made a change in the CPanel backend?

No, we deleted it.

Also, I merged both topics since they are about the same issue.

How do you contact support directly when CPanel tells you to do so?

I can’t use my main email currently and it’s a real problem.

Cheers