Cannot Connect to FTP via other web based clients

When I try and connect to the FTP server (ftp.epizy.com), all the clients I use come up with ‘The username or password is incorrect.’ I am 100% sure they are correct, so why isn’t it working?

Can you try to connect with FileZilla instead of web based clients? FileZilla is really good and if it doesn’t work, it gives you a lot more diagnostic information which could help us.

There are two things I have found out that are stopping me. The FTP server seems to only support connecting with passive mode, and the login doesn’t like just a username and password, it seems to need a special c-panel token, otherwise it just comes up with session expired. Only the file manager built into the panel can generate this, so how do I use other clients, or can I not?

I also have another question. You advertised your free hosting to have apache with .htaccess but when I try and use .htaccess to redirect to https, remove file extensions and specify error pages, it doesn’t work. Am I using the wrong code, as it worked with my last hosting provider, or is something wrong with .htaccess. I have the file saved in htdocs, with one in each sub directory of this too.

@thecoderszone said:
There are two things I have found out that are stopping me. The FTP server seems to only support connecting with passive mode, and the login doesn’t like just a username and password, it seems to need a special c-panel token, otherwise it just comes up with session expired. Only the file manager built into the panel can generate this, so how do I use other clients, or can I not?

The web based file manager uses encrypted tokens for the authentication. But, I know for a fact using FTP username and password works fine with FileZilla, as long as you’re using the correct credentials.

Just try with FileZilla first. I know FileZilla is supposed to work, so trying it will help you determine whether it’s your account or the FTP client giving you problems.

@thecoderszone said:
I also have another question. You advertised your free hosting to have apache with .htaccess but when I try and use .htaccess to redirect to https, remove file extensions and specify error pages, it doesn’t work. Am I using the wrong code, as it worked with my last hosting provider, or is something wrong with .htaccess. I have the file saved in htdocs, with one in each sub directory of this too.

Can you be more specific? What are the exact rules you’re using and what do you see?

Our code is as follows:

ErrorDocument 400 http://https://thecoderszone.com/error/400
ErrorDocument 401 http://https://thecoderszone.com/error/402
ErrorDocument 403 http://https://thecoderszone.com/error/403
ErrorDocument 404 http://https://thecoderszone.com/error/404
ErrorDocument 503 http://https://thecoderszone.com/error/500

RewriteEngine on
RewriteCond %{HTTPS} !on
RewriteRule (.) https://%{HTTP_HOST}%{REQUEST_URI}
RewriteEngine On
RewriteCond %{REQUEST_FILENAME}.html -f
RewriteRule !.
\.html$ %{REQUEST_FILENAME}.html [QSA,L]
RewriteEngine On
RewriteCond %{REQUEST_FILENAME}.php -f
RewriteRule !.*\.php$ %{REQUEST_FILENAME}.php [QSA,L]

Redirect 301 /cookies /policy/cookies
Redirect 301 /cookies.html /policy/cookies
Redirect 301 /Cookies.html /policy/cookies
Redirect 301 /Cookies /policy/cookies
Redirect 301 /PrivacyPolicy /policy/privacy
Redirect 301 /PrivacyPolicy.html /policy/privacy
Redirect 301 /termsandconditions /policy/terms
Redirect 301 /termsandconditions.html /policy/terms
Redirect 301 /ContactUs /contact/contact
Redirect 301 /ContactUs.php /contact/contact
Redirect 301 /AboutUs contact/about
Redirect 301 /AboutUs.php contact/about
Redirect 301 /sitemap.xml policy/sitemap.xml
Redirect 301 /games.php /games/
Redirect 301 /techtime.php /techtime/
Redirect 301 /games.html /games/
Redirect 301 /techtime.html /techtime/
Redirect 301 /account/materialize.css /css/materialize.css
Redirect 301 /account/materialize.min.css /css/materialize.min.css
Redirect 301 /account/materialize.js /js/materialize.js
Redirect 301 /account/materialize.min.js /js/materialize.min.js
AuthName “admin”
AuthUserFile “/home/thecoder/.htpasswds/public_html/passwd”

We’ve uploaded our private key and certificate in the SSL/TSL Cpanel area but we get an error 500 and it says 500 Error, please check your php script / enable display_errors in your cpanel. However, we know that the index.php file is not the problem since when we get rid of our .htaccess file the website works fine, but without SSL. Help would be appreciated.

OK, that’s a pretty complicated .htaccess file and I don’t immediately see anything which could explain this issue.

You could try to start again with a blank .htaccess file and add the lines back one by one. That way should at least help you figure out which line is causing the problem.

without
AuthName “admin”
AuthUserFile “/home/thecoder/.htpasswds/public_html/passwd”

the 500 error goes away but it instead says the page is redirecting too many times. Getting rid of

RewriteEngine on
RewriteCond %{HTTPS} !on
RewriteRule (.) https://%{HTTP_HOST}%{REQUEST_URI}

Fixes the redirect problem but leaves us without https. Help Would be Appreciated.

correction, the 301 redirects are causing the 500 error

Sorry, please ignore my last two replies. The 500 error was caused by two lines of the 301 redirect code, because I forgot to include a slash before the directory to redirect to for two of the redirects. That is now working, but I have one more problem with .htaccess and this is my https redirect. I would like my site to redirect from http to https, and the code is:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
When I put this in, it Chrome comes up with “ERR_TOO_MANY_REDIRECTS” but not when I take it out. It has always worked before, so why is it not working now?

Some scripts (including Wordpress) redirect people to the correct domain and protocol as well, so it could be that your .htaccess rules are redirecting people to https but your script is redirecting people back to http.

Without the .htaccess redirect, are you still redirected from https to http? If so, you have to check what’s causing that redirect.

We have no scripts, and without the code, it just leaves whatever you type in as it is. With the code, it should re-direct whatever it is to https, but instead it comes up with the error.

Do you have any idea why this code doesn’t work with your servers, as it is the standard https redirection code. If there is no way to get it working, can I redirect to https in any other ways, as sign in and sign up pages display a not secure warning while using http.

certification expire error how to fix it

@sameera said:
certification expire error how to fix it

Please don’t hijack old topics.