Cannot access IP address

When opening the phpMyAdmin dashboard through the cPanel I receive an error that IP addresses are blocked by some kind of filter. How can I access my database?

Disable the “some kind of filter”?

It seems like a virus scanner or firewall blocking your access to our phpMyAdmin. You should whitelist the phpMyAdmin IP/URL in there if you want to access it.

6 Likes

Unfortunately, I can’t because I don’t have permission to turn the filter off. Is there a reason why Infinity Free uses an IP address instead of a domain?

PHP MyAdmon is access over an IP because it is easier to manage, and it rarly ever matters.

2 Likes

What do you suggest me to do in this case?

This

This is an internal IP, so theoretically it’s safer.
The only way databases can be accessed is either via your website or control panel

4 Likes

The problem is, I can’t because I don’t have access to the filter settings. Isn’t there any alternative method?

Can you try install Adminer via Softaculous and see if you access the database from there?

image

5 Likes

Please see the PM I sent you to see if it works.
If not, @KangJL’s suggestion will have to be what you use.

4 Likes

Thanks, Adminer works, but phpMyAdmin doesn’t (I get a 502 Bad Gateway error). How can I fix this issue? I prefer working with PMA.

2 Likes

Try on another hosting account?

3 Likes

In my experience phpMyAdmin is a bit finicky to setup yourself. We also run a customized installation of phpMyAdmin and it might be that a standard phpMyAdmin installation doesn’t work with our database servers.

Adminer is a lot easier to use in that regard.

It’s not perfect, but I would suggest to either use Adminer to manage your database, or use a different network of a VPN to bypass the filters that prevent you from using our phpMyAdmin installation.

5 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.