421 3900 users (the maximum) are already logged in, sorry (and file manager issues)

I got an update from iFastNet this morning: this issue is caused by a malfunctioning storage server. To fix this issue, someone needs to go down to the data center and repair this, but due to quarantine measures it’s hard to get people there. Someone should be able to go there on Monday and fix this issue.


Thanks for the update and tenacity with solving this one.


Take your time and stay safe!

Now seems to be working fine, both my websites are uploading again via ftp.

Many thanks to whoever went down there to fix it.


Hopefully it will be sorted soon, as I struggled to backup all our sites last month… We will have another go this week and see how we get on…

still ongoing, trying to connect with filezilla

Status: Connection established, waiting for welcome message…
Response: 421 3900 users (the maximum) are already logged in, sorry
Error: Could not connect to server
Status: Waiting to retry…

Not working for me also.
My clients are just shouting at me.

Quarentine going on, so I don’t want to upgrade also.

The system maintenance was completed yesterday morning (UTC). This did result in a large share of all websites being down for around 45 minutes, causing them to show timeout errors.

The maintenance has been completed, and it should have restored all websites and solved the FTP issues. But I’ll be keeping an eye on the reports to verify whether that’s actually the case.


Still the problem is not solved. Please do something. I’m still getting this error. It is working sometimes, but taking many attempts to upload a file.

Yes, it does seem that the attempted fix from Monday has improved the performance somewhat, but hasn’t fully solved the load issues. The next action is currently being investigated, but it’s still not certain what exactly the solution is.


Since yesterday the problem seems to be solved.

I experienced a

421 6900 users (the maximum) are already logged in, sorry

(note the 6900)

yesterday morning, and then it started working as fast as before the issue.

I know it’s too early to speak, but anyway thanks to iFastNet and @Admin for the effort!

The capacity and performance has been increased so it should be a bit better now. But there are still capacity issues and still outages related to too many connections. So it’s not quite resolved yet.

1 Like


FTP software = FileZilla

I am still having 2 issues with your FTP service .

Error 1

Error: GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error: Could not read from socket: ECONNABORTED - Connection aborted
Error: Disconnected from server

Error 2

Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1457 of 6900 allowed.
Response: 220-Local time is now 15:30. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220 You will be disconnected after 60 seconds of inactivity.

This is caused by the server closing the FTP. Our server kills inactive FTP connections quite quickly and aggressively, so this is normal. But as long as you login, immediately navigate to the path you wish to transfer files to or from and initiate the transfer, everything should work. If you come back some time later to do more transfers, you can just disconnect and reconnect your FTP client and initiate the new transfers.

What’s the error? Not every log line is an error, you know. This is just the normal welcome message sent by our FTP server.

1 Like
Status: Connecting to…
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

@Admin Is their a problem with your FTP Services ??

Yes, there are FTP issues, hence why this topic was created.

Although those two lines don’t correlate with the issue description above, so they may be unrelated.

So can you please create a new topic and describe the issue in more detail here? The symptoms of the known issues are well documented in the first post. If you experience something else, you’re not experiencing this issue, which means you’re hijacking this topic with unrelated questions. Please don’t do that.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Just to give an update on the issue.

About a week ago, iFastNet implemented a patch to combat some of the outages you’ve seen with the FTP service in the week before. Since then, there haven’t been any further outages with the FTP service.

iFastNet is still working on improving the FTP service, which will help to improve the reliability and performance of the FTP service and the hosting service in general.


iFastNet has completed their performance optimization for the FTP service. You should find that all transfers are a LOT faster than they were before.